Jump to content
Division-M Community
Sign in to follow this  
oj88

[Resolved] WHS2011 keeps forgetting the shared folders

Recommended Posts

Running DB 1.9 and I just noticed recently that when I reboot the server, the following shared folders become "Missing" in WHS Dashboard:

 

Music > P:\ServerFolder\Music

Recorded TV > P:\ServerFolder\Recorded TV

Videos > P:\ServerFolder\Videos

 

The weird thing is, Client Backups is also pointed to P:\ServerFolder\Client Backup but it doesn't go missing after a reboot.

 

Anybody else having similar issues?

 

 

To illustrate, this is how everything should look:

GoodShares_zpsff4af8e8.png

 

After a reboot, three shares have become "Missing".

MissingShares_zps2ffb83cf.png

 

In both cases, the DB pool "P:" is already accessible.

Share this post


Link to post
Share on other sites

@oj88, Question and observation...

 

From a client PC on your network can the client "see" the folders that show missing in the Dashboard from Windows Explorer?

 

On my system I do not have any shares that are not in the pool. Wonder if this is related to the problem and is why all my folders are still available?

Share this post


Link to post
Share on other sites

Other stuff. It looks like there are multiple threads here that speak of this problem with DB 1.9.0.0. If I'm remembering correctly (which may not be the case) from my own "getting started" with DB... If a shared folder existed, but showed as "missing" in the pool I could use the create missing folder option by selecting it in the Dashboard and define it on the pool drive. It would re-add the folder non-destructively and all would be good. Again, this memory is from well over a year ago, if you have one of your missing folders that is easily recoverable, you could try this and see if my memory is correct.

Share this post


Link to post
Share on other sites

When they go missing in Dashboard, they also disappear in the network. This was working fine before.

 

And that's exactly what I had to do after every reboot: Recreate them in Dashboard. But the problem is, it goes missing again after the next reboot. Somehow, the changes doesn't stick past a restart.

Share this post


Link to post
Share on other sites

The only difference I  can see from your system to mine is that I don't have any non-pool shares on my WHS2011 box and you do. I notice that you're first non-pool folder is the "Documents" folder which would be the 2nd folder in collating sequence by folder name. A test for this being related would be to move the Documents folder to the pool, reboot and see if Client Computer Backups and Documents showed and then Music, Recorded TV and Videos were missing. If it followed this theory it would tell Anthony where the error in the code is.

Share this post


Link to post
Share on other sites

Would the placement/order of the shared folder in the list have any bearing? The list is actually sorted by Location (reverse alphabetical).. So all "P:\..." entries goes before "D:\...".

Share this post


Link to post
Share on other sites

I was just looking at the folder names only in collating sequence. Client Computer Backups is 1st (ignoring location) Documents is 2nd and not in the pool. Then the rest of the pool folders show as missing and do follow Documents in collating sequence by folder name (ignoring location). It was just a theory so I don't know if it would have any bearing.

Share this post


Link to post
Share on other sites

Thanks w3wilkes for helping.

 

Let me just update after much testing that it appears that ANY activity I do in the Server Folders tab of the Dashboard does not persist after a reboot. To test, I did the following:

 

Created a folder called D:\ServerFolders\Test

I then clicked on Add a Folder in Dashboard, called it Test and pointed it to D:\ServerFolders\Test

 

This created the shared folder called Test and I can confirm that it is accessible from the network... even copied a few files to it.

 

I then proceeded to restart the server. After booting up and giving the server a few moments to settle down, the Test share is no longer listed in the Dashboard. As in, there's no trace of me even creating it. Though the actual folder in D:\ServerFolders\Test is still intact.

 

And as always, Music, Videos and Recorded TV shows up but with a status of Missing.

 

I'm starting to think that this may be more of a WHS/Dashboard issue. Uggghhh.. I'm almost at the end of my rope.

 

This could be a long shot but I have to ask anyway; Without resorting to backups, is there currently any way to fix WHS2011 using the installation DVD? Like, re-copy missing or corrupted files?

 

Thanks!

Share this post


Link to post
Share on other sites

The shares are all still there, just not visible because of an issue with the order some Windows services are starting. To gain access simply restart the DB service.

We have addressed this issue with v1.9.1.0 which is now available.

 

Download here

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...