Jump to content
Division-M Community

Torrent client incompatibility?


wrongworld
 Share

Recommended Posts

I'm using Drive Bender 2.3.0.0 on a WHS 2011 / HP Data Vault X510 server. I have a single DB pool composed by two 2TB disks, plus another 1 TB disk. All the directories located on the pool are set to duplicate themselves among the pool, there is no landing zone.

 

On this server I have a torrent client, qBittorrent, that I use quite seldomly. The client is set to use a Downloads directory located on the DB pool, and it's set also to preallocate the space for the file(s) being downloaded. Every once in a while I fire the torrent client, but every time the torrent stops after few seconds due to some access error on the disk. I then restart the torrent and the download is then completed without other failures. I have tried moving temporarily the download directory on a non-pooled disk (it's not an option for me, the drive is used for the WHS clients backup), and it works well there. I've tried to change the torrent client with uTorrent but the same behavior persists. I had the same problems with Drive Bender 1.9.5.0, indeed the switch to v2 was mainly driven by the need to solve this issue.

 

I remember quite well that I've never had problems like that when the same hardware was running WHS 1.0, using Microsoft's Drive Extender. Could it be that the something gets triggered in Drive Bender, such as replicating the preallocated file space, which disturbs the activity of the torrent client?

 

I'd like to know if anybody else has ever experienced the same issue, and if eventually you've found a solution / workaround.

 

Thanks!

 

Edit: typos

Link to comment
Share on other sites

I have observed similar behavior when using uTorrent. My workaround is to configure "Put new downloads in" to a folder in a non-pooled drive (D:) to use as a scratch space while the files gets downloaded.

 

I then also configured the "Move completed downloads" to a folder in my pooled drive (P:) to free up space on the non-pooled drive once the download is complete.

 

be0f2a43-9faa-4d2b-a92d-143413c301fb_zps

Link to comment
Share on other sites

Well, first of all thanks for having reported your experience. You are confirming my suspect: having the file being "torrented" on a DB pooled drive is causing an error in the torrent client. Since the torrent, once added, starts for few seconds before being disrupted, and since when the size of the downloading file is not so big (can't say how much big, probabluy tens of MB) the glitch sometime doesn't occur, I inferred it has to do with the big file being pre-allocated and afterward being duplicated, while at the same time the torrent client tries to fill the "container" with the incoming data.

 

I'll see if I can make some space on a unpooled partition, I don't like too much the idea but it's better than finding your torrent stopped. Eventually, the DB developer(s) could come out with some info or request more debug data to nail down the issue.

Link to comment
Share on other sites

I should mention that it doesn't always happen. Right now, I have a 170GB torrent being downloaded. Since it is too big to fit the scratch drive (D:), I've set uTorrent to svae it directly to the pooled drive. It's been at it for three days without issues.

 

Usually when I encounter the error, the DB WHS2011 connector also times-out. This is cured by restarting the Dashboard process. To get uTorrent downloading the file again, as you've observed, I have to manually start the download. This seems to point to a DB component that would occassionally lock up. Probably happens more often when uTorrent is using it due to the multiple sessions. Hope this helps your support request.

Link to comment
Share on other sites

Well, I have received an answer from the company's tech department. They state they were never able to reproduce the error, so it's difficult for them to investigate the case. They'll add the issue to the list of things to be re-checked, but they also wrote that the todo list is quite long (hence, no guarantee that the problem will be eventually fixed, as I read it)

Link to comment
Share on other sites

  • 3 weeks later...
  • 5 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...