Jump to content
Division-M Community
Anthony

Drive Bender v3.1.0.0 released

Recommended Posts

Release v3.1.0.0 release (2018-12-03)
[ b ] Fixed an issue network security errors.
[ b ] Fixed an issue with Drive Idle terminating.
[ n ] Drive Idle now defaults to disabled.
[ n ] Side Channel Protection can now be enabled via the setting.
[ b ] Closing the Drive Bender Manager's config window was updating custom setting even when no setting were changed.

Release v3.0.9.0 beta (2018-11-09)
[ b ] Further improvements on Drive Idle performance.
[ b ] A number of bug fixes on the Drive Idle feature.
[ n ] Added notification options to the Pool Firewall.
[ b ] A number of minor network share related issues.

Release v3.0.8.0 beta (2018-10-15)
[ n ] Added new "Side Channel Protection" feature. (DB-228)
[ b ] Installer not updating all dependencies correctly. (DB-231)
[ b ] Network services staring but not seeing mount point, we have needed to restart "server" for network path to appear. (DB-227)
[ b ] Drive Idle performance slow, and for some users files missing during file enumeration. (DB-233 & DB-239)
[ b ] Mount point name appearing as "Local Disk". (DB-226)
[ b ] Empty pool purging is causing an issue on new installs. (DB-229)
[ b ] Drive Bender Manager throwing an error when first starting on some systems (DB-230)
[ b ] Network shares can display security issues (DB-238)
[ b ] File system health check could create folders using a file name (DB-240)

Release v3.0.0.0 beta (2018-07-21)
[ n ] Added new "Pool Firewall" feature (note disabling the "List" option is currently not available). (DB-216)
[ n ] Added file enumeration cache feature (FEC), this is part of the new "Drive Idle' feature. (DB-218 & DB-220)
[ u ] Empty pools are purged on restart. (DB-202)
[ b ] Improved network share handling, including a number of network share bug fixes. (DB-203)
[ b ] Network nodes being restored after having been removed from a pool. (DB-213)
[ b ] A pool can fail to mount if a network share failed to connect. (DB-214)
[ u ] Some USB based removable drive were not being detected. (DB-215)
[ u ] Improved mount point checks and loading times. (DB-204)
[ u ] Hard limit on log file usage improved. (DB-219)
[ u ] Fixed a number of driver installation issues. (DB-223)
[ b ] Fixed several issues with balancing and landing zone clearing. (DB-217)
[ u ] Improved balancing performance. (DB-217)
[ u ] Thread deadlocking issue resolved, and improved thread marshalling for better performance. (DB-225)
[ b ] Fixed a number of server related bugs.

Download here

Pool firewall configuration We have posted a "How to" on the Pool Firewall, you can access via support at https://support.division-m.com/hc/en-us/articles/360000366936

Share this post


Link to post
Share on other sites

Excellent stuff! Thank you!
Had an issue with upgrading from v2.7 and DriveBender.dll as I did upgrading to 2.7. Luckily I still had the support emails from before that told me where to get the new DLL from post install which worked fine otherwise!!

Share this post


Link to post
Share on other sites
59 minutes ago, JonnyManiac said:

Excellent stuff! Thank you!
Had an issue with upgrading from v2.7 and DriveBender.dll as I did upgrading to 2.7. Luckily I still had the support emails from before that told me where to get the new DLL from post install which worked fine otherwise!!

You should update your existing Support Ticket, or raise a new one, as I didn't have any DLL issues going from v2.7 to v3. 

 

Share this post


Link to post
Share on other sites

Must have been asleep at the wheel as I missed this announcement. I'm now caught up and this release is running. Anymore I always do the deinstall / reinstall method and had no issues. Looks like DB is doing a validation run on initial startup. Did some looking around and so far so good.

Thanks Anthony and Happy New Year! I'll tip a cold one for you. While you're enjoying summer it looks like I've got to go out and shovel snow - again!

Share this post


Link to post
Share on other sites

Update to v3.1.0.0 today as well.

 

So far so good, but I never had any issues in the previous beta.

 

Keep shovelling the snow [mention=23]w3wilkes[/mention]

 

 

 

 

Share this post


Link to post
Share on other sites
1 minute ago, JohnDoe said:

Checked the new version, the Adobe Lightroom Classic CC still does not work with the drivebender's pool ☹️

Gives an error when working with the preview cache.

What do you mean it doesn't work?

Have you disabled the DB firewall? 

Have you raised a Support Ticket? 

 

Share this post


Link to post
Share on other sites

Upgraded from 2.8.0.0 to 3.1.0.0

Windows Server 2012R2

uninstalled 2.8.0.0
reboot
install 3.1.0.0
reboot
everything works perfectly fine !

thanks anthony for another great release !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...