Jump to content
Division-M Community

Replacing drive in pool issue


Recommended Posts

Dear all,

I have run into an issue when replacing a drive in my pool with a new larger drive. I was in correspondence via the support ticket system but hoping to enlist the help of the community as it has become a time-sensitive issue with work documents.

I have done the following: attached new drive (via USB as there were no SATA ports remaining), mapped new letter to full drive, copied contents from full drive to new drive, shutdown and exchanged old drive with new drive, proceeded to restore pool as per guide (https://support.division-m.com/hc/en-us/articles/214026383-How-do-I-restore-a-pool-using-the-connected-drives-).

Upon restoring function used, the DB client advised for a restart as there were some issues with the pool. Following restart, the pool has now gone and I am prompted to connect to the DB server with no success; it also takes >10 minutes to access the client with it being non-responsive before the prompt appears.

Only the new drive is accessible/visible. Please find attached some captures. 

I found the relevant guide (https://support.division-m.com/hc/en-us/articles/214025563-Upgrading-issues-and-fixes) but did not want unless advised.

Help much appreciated, thank you.

Kind regards,

Kim

image.png

image.png

image.png

Link to post
Share on other sites

Did you follow the procedure for swapping a drive, or do it within Windows?

You should have added the new drive to the pool and then removed the old drive, which would have moved the contents and then removed the drive.

You may have to out the old drive back into your PC and restart and see if the pool comes back.

How many drives do you have in the pool, without the new one?

Link to post
Share on other sites
Posted (edited)

Thank you for your reply CBers.

I apologise, I am unsure of the procedure you are speaking of however I followed these steps as advised by the support team:

Quote

1) Attach new drive via USB
2) Map a drive letter to DB1 (see - https://support.division-m.com/hc/en-us/articles/214027203-How-do-I-map-or-remove-a-drive-letter-to-one-of-the-drives-in-the-pool-)
3) Copy all files from DB1 to new drive.
4) Shutdown, replace DB1 with new drive
5) Reboot, then restore the pool as per - https://support.division-m.com/hc/en-us/articles/214026383-How-do-I-restore-a-pool-using-the-connected-drives-

The conundrum was that I had no more SATA ports to accommodate the straight forward method so was advised to plug in the new drive via USB (original enclosure) and move files over this way. Was it possible to add the new drive to the pool - whilst it was connected through USB - and retain its position in the pool when I exchange it with DB1's SATA port? I did not think to do this, and only mapped the drive and copy its contents over.

My first instinct was to put the old drive back and it was unsuccessful unfortunately, although I don't quite recall the results. I will try again tonight and post what occurs shortly.

Without the new drive, there are presently 2 drives in the pool.

Edit:

This is what occurs when I plug the old drive back in.

 

image.png.eca4ab4dee9e0eff1503c46a250e1a7f.png

Edited by kim8
Update to post.
Link to post
Share on other sites

You copied all of the hidden GUID folders that reside in the root of the drive?

This is the manual way of swapping drives:

https://support.division-m.com/hc/en-us/articles/214025823-How-do-I-manually-remove-a-drive-from-the-pool-

I would first have tried to SWAP the drive via the UI, but looks like you've gone past that.

You could delete the pool, move the content on the drives to the root of the drive, remove the hidden GUID folders and then start afresh, by creating a new pool and adding your drives one at a time to the new pool.

That's one way of getting it up and running and something I have had to do a few times, but it all depends on how confident you are and know exactly what you're doing.

Link to post
Share on other sites

Unfortunately I may not have. I only copied everything including the annotated folders with random strings. I have hidden folders enabled but I honestly did not set out to find them and ensure they were copied. As you can tell, I am a complete newb. Could you please advise how I may find them in the root of the drive?

Yes, I will have to do the UI method next time.

Would uninstalling DB simply allow the drives to show up in explorer? I always had the idea that files were distributed somewhat between the drives in the pool. If so, would they sort themselves out or am I incorrect in assuming how they work?

I have sent my DB log files to support as requested. For now, I will wait on further course of action before resorting to deleting the pool.

Thank you CBers.

Link to post
Share on other sites

Apologies, the GUID folders aren't hidden.

In the root of the drive, you should have 1 folder and 3 files. The folder is where your content is stored.

You could move everything from that folder to the root of the drive, then delete the folder and files, so all you have in the root of the drive is your content.

If you do the same with all of the drives in your pool, then you will be back to before ever creating a pool.

Delete the pool from the DB UI and reboot your PC.

Then once it's back up, start from the beginning again, create a pool and add the drives one by one to it.

This is how I have done it in the past when DB got "corrupted".

Hope that helps.

Link to post
Share on other sites

Thank you, it's starting to make a lot of sense. I can see that some of my files are in the folder with some missing documents in sub-folders. I would think that they are in the other drives in the pool under the same sub-folders?

I am unable to determine this as my DB client keeps prompting to connect to the server which fails. As a result, I can not access the UI to map a letter to the other drives, would you know how to do this?

image.png.cd5d14f2f871ebb39ac0fc5ff9410b25.png

If I am also able to map drives and access them from explorer, how may I erase the pool if the client is inaccessible at this stage? Would a simple uninstall work coupled with following your procedure above (move all content from folder to root and delete folder + 3 files)? Upon reinstallation of DB, would it allow me to create a new pool since those folders/files were removed? 

Thanks again CBers.

Link to post
Share on other sites

I would uninstall DriveBender, then reboot and start the DB install again.

 

If that still doesn't work, then uninstall and remove all entries in your registry relating to DriveBender, then reboot and reinstall.

 

You can map letters to your drives via Disk Management.

 

 

 

Link to post
Share on other sites

All is well again! I went ahead and reinstalled DB and it indirectly prompted me to replace the old drive with the new one, and afterwards, restored the pool on its own. Another plus is now I am on the latest version. I was dreading this step but it turns out it was the most simplest way forwards. Thank you so much, I really appreciate it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...