Jump to content
Division-M Community

Windows 10 build 20161 - DB service stuck starting - cannot mount pool


Recommended Posts

Just curious if anyone else has had this issue?

Updated to Windows 10 build 20161, the pool wouldnt mount, DB service is stuck on starting... so i yanked my ssd out, put a spare ssd in installed a fresh build of Win10... installed DB, attached my drives, and it found a previous pool, offered to bring it online... i said ok. Nothing happened... 

Rebooted, and the DB service was stuck again. Deleted the mount point, and tried to create a new one. The DB service is running fine, but the Add mount point task is stuck on 0%... nothing happening.

I have raised a ticket for this, but just wondering if anyone else has had this.. or knows how i can get my pool back.... this has happened to the last 2 builds of Win 10 insider...

Worst case, i install the old ssd, and revert to previous build of Win10 that still worked.

Edit: It must be an issue with the Iron Branch of Win10 then. old SSD has Manganese on it, build 19635 ... that works 100% fine. as soon as i hit the Iron branch... dead.

Link to post
Share on other sites

Update - So, i decided to try StableBit Drive Pool on another pc with windows 10 (Iron Branch build 20161)... and that also doesn't work. Reading their forums, same issues with newer Iron Branch builds...... guess we will have to wait until a new DB version comes along, or MSFT fixes it!

Another post on even Storage Spaces broken https://mspoweruser.com/the-windows-10-may-2020-update-may-be-causing-major-hard-drive-management-issues/

Link to post
Share on other sites

Update: Had a response to try uninstall DB, re-install, and reboot... try again. To this end, again, no luck.

 

My testing steps and response back below:

So, i did try that, a few times while i was on build 20161. It would seem the issue started on build 20150 of Win10 2004. Before build 20150 we were on the MN (Manganese branch) ... now we are on the Iron branch.
I also did a fresh install of Win10 ... build 20150, did all updates and drivers... installed DB... rebooted... DB came up fine, shut down, attached all my drives, powered up, DB found the pool, and started to remount... after an hour, nothing was going on. 
Rebooted again, and the DB service was stuck in starting mode... Win10 was extremely sluggish, explorer.exe kept crashing.
Deleted the pool, and rebooted. DB service was fine again. Attached a USB SSD, tried to build a fresh new pool, and again, nothing happened. Trying anything in DB, would come up with a note of attempting mount point.
Uninstalled DB, rebooted... updated Win10 to build 20161.. performed the same steps as above.. no luck again.
Pulled out the SSD, and put my old SSD back with build 19635... all works as expected again.
 
I installed DB on my normal daily PC, that is also running 20161. DB if fine until i try create a pool.
Created a new pool, added a mount point, it remained on Creating Mount Point 0% for about 10 minutes... didnt progress. Cancelled the operation, and added a single blank SSD, which said completed.
No new drive appeared in windows explorer (H:)
Rebooted my pc, and system was basically unusable... explorer.exe kept crashing, i eventually got services up, and DB service was stuck starting. Tried net stop drivebender, service unresponsive due to starting or stopping.
Eventually, managed to get to explorer, and grabbed the log files and attached them.
Going to uninstall DB now... and await your response :)
 
Have you tested on build 20161 or any Iron Branch Windows 20 2004??
Link to post
Share on other sites
  • 3 months later...

Just an update, as 20H2 dropped. Still not had anything concrete back from DB Support, and have asked the question if there may be a new version eminent that will work with 20H2. 

Unless anyone is already on 20H2 and can comment on whether DB works on it or not??

Link to post
Share on other sites
4 hours ago, w3wilkes said:

Thanks for the update Anthony! The OP doesn't say what version of DB they're running. Hopefully they are trying with 3.7.0.0. I've always thought it's a good idea to put DB version and OS version in your signature.

Indeed, I am on 3.7.0.0 .... 20H2 is still the 19x branch build.... 

Link to post
Share on other sites
11 hours ago, w3wilkes said:

Interesting, I just did a Check for updates and don't see that 20H2 has been dropped. Where is the official release 20H2 for Win10 pro?

It is a staged rollout, and it is from the 19x branch build, so if you are on 2004+, i doubt you will get the option to download. But, you can get 20H2 from MSFT now, using the media creation tool: Download Windows 10 20H2 (microsoft.com)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...